We've moved to http://www.booksellingonlineblog.com

Monday, February 28, 2005

OT: Patch your Mozilla!

Mozilla recently announced that Firefox is vulnerable to massive security breaches. An upgrade is now available. Read the official press release or go to the Mozilla upgrade page.
Digg